SQL Server Management Studio 18.0 (preview 4) is now available, and it adds support to the new SQL Server 2019 CTP 2.0 version.

SSMS now requires NetFx 4.7.2 or greater:

  • This dependency on NetFx 4.7.2, implies that SSMS 18.0 can’t be installed on Windows 8, older versions of Windows 10 (requires version 1607), and older versions of Windows Server 2016 (requieres version 2017). SSMS setup will block on those operating systems. Moreover Windows 8.1 is still supported.

Some of the innovations that it introduces are:

  • Support for SQL Server 2019, compatibility level 150
  • Improved Intellisense for SQL Server 2017
  • Possibility to configure Autgrow for all files in a group of files, AUTOGROW_ALL_FILES
  • Eliminating the ability to configure Lightweight Pooling and Priority Boosat from the SSMS GUI
  • RTO (Recovery Time Objective) and RPO (Recovery Point Objective) in Always On Dashboard
  • Data Classification: updated the recommendations

You can find more detailed information here: https://docs.microsoft.com/en-us/sql/ssms/sql-server-management-studio-changelog-ssms?view=sql-server-2017

And the installer can be download here: https://docs.microsoft.com/en-us/sql/ssms/download-sql-server-management-studio-ssms?view=sql-server-2017

Recent Posts

Leave a Comment

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.